Death to installers


One of the things that has bugged me about Xuggler from day-zero was the need to separately build and install the native code BEFORE you can do anything useful.  With Xuggler 5.2, for the most common operating systems, this is no longer necessary.  Happy day.

http://www.xuggle.com/xuggler/downloads

Native code is what gives Xuggler its power, but native code to Java users is strange.  We invested a lot into Xuggler to make it POSSIBLE to build it on many operating systems, but time and time again we’ve found that is still too high of a bar for most users. Who wants to worry about installing C++, C and assembly compilers?  Answer: almost no one (myself included).

What was worse than building though is the need to install Xuggler BEFORE it could run.  This mean setting some obscure operating-system specific environment variables and hoping for the best.  Ugh.

So now, with Xuggler 5.2, the default Xuggler installation INCLUDES all the pre-compiled native code for the 6 most commonly requested operating systems, and can find that code WITHOUT setting environment variables.  That means for Windows users, Xuggler now looks like any other Jar file.  It includes support for both 32 bit AND 64-bit operating systems.  Neat.

There are a few more bug-fixes coming in Xuggler 5.3, but otherwise, we’re narrowing down on the final release of Xuggler for the 5 series.  Enjoy.

- Art

About these ads

11 Responses to Death to installers

  1. kdobrik says:

    Hi,
    thank you for the effort to provide 5.2.
    I am trying to setup a sample using 5.2. but I am constantly receiving the following error:

    ERROR com.xuggle.ferry.JNILibraryLoader – Could not load library: xuggle; version: 5; Visit http://www.xuggle.com/xuggler/faq/ to find common solutions to this problem

    I set up Eclipse project with Maven nature, so xuggle 5.2. is set into the classpath. Additionally I tried to setup -Djava.library.path pointing to unpacked version of the jar, so native libs can be loaded. Anyway, I did not succeeded to overcome the problem.

    Please, advise.

    Thank you in advance,
    kdobrik

  2. x says:

    It keeps on throwing Exception in thread “main” java.lang.UnsatisfiedLinkError: no xuggle in java.library.path >> how do i get xuggle.dll?Java 6 64 @ Windows 7 64

  3. x says:

    nevermind, eclipse couldn’t find it inside jar

  4. iqbalyusuf says:

    I ran into similar problem. Look at this group post thread.

    https://groups.google.com/forum/?hl=en&fromgroups#!topic/xuggler-users/XAWvMk8FYfw

    Look at Winston’s reply, that solved my problem. I am also using Eclipse. I went to “Run Configurations”>”Environment”> then create a Variable “PATH” and add the location for libxuggle-5.dll file.

  5. This should not be necessary if you force a redownload of the jar files for 5.2. It will be fixed completely in 5.3 (which should go out sometime this week).

  6. kdobrik says:

    Thank you for the responses guys, I will try to fix it.

  7. knathdrak says:

    Anyone able to get this to work with 5.2 and Maven? I tried using the test project xuggle-xuggler-test and all the test fail due to the following error java.lang.UnsatisfiedLinkError: no xuggle in java.library.path

    Reading the download page, I should no longer need to download the .jar file and setup the path environment variables right?

    I have double checked my pom.xml and it looks right, in NetBeans it downloads the xuggle-xuggler5.2.jar in the dependencies.

    Any help would be greatly appreciated.

  8. Hi kdborik,
    can you ask your questions on the xuggler-users forum — that’s where I try to answer:
    https://groups.google.com/forum/?fromgroups#!forum/xuggler-users

  9. This is now confirmed fixed in 5.3 which should be ready for download now. Give it a whirl. Make sure you delete the old libxuggle-5.dll that you put in your PATH.

  10. kdobrik says:

    Hi schrodinger09,
    I saw your comment today. Do you still want me to ask this question into the forum
    https://groups.google.com/forum/?fromgroups#!forum/xuggler-users ? I suppose, it still a good idea, in order to have this collected into the forum’s knowledge base?

  11. Danny walker says:

    Love the new all in one jar :)
    Previous versions had me pulling out my hair on mac osx and Linux, but in the latest version, I just added a maven dependency and I was running no problems – bliss..

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: